CVE-2023-46104PYSEC-2026-1167BIT-SUPERSET-2023-46104GHSA-95MG-JGFX-54V9
Apache Superset: Allows for uncontrolled resource consumption via a ZIP bomb
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.1.3, 3.0.1, 2.1.2, 3.1.0rc1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or datasets. This vulnerability exists in Apache Superset versions up to and including 2.1.2 and versions 3.0.0, 3.0.1.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Apache Software Foundation Apache Superset
fixed in 2.1.3; From 3.0.0 · fixed in 3.0.1
- apache-supersetPyPI
fixed in 2.1.2; From 3.0.0 · fixed in 3.1.0rc1
- apache-supersetPyPI
fixed in 2.1.2
- apache-supersetPyPI
From 3.0.0 · fixed in 3.1.0rc1