Skip to main content
← All vulnerabilities
CVE-2023-4317

Incorrect Authorization in GitLab

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 16.4.3, 16.5.3, 16.6.1
None on Exploit-DB, Metasploit or GitHub

Summary

An issue has been discovered in GitLab affecting all versions starting from 9.2 before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. It was possible for a user with the Developer role to update a pipeline schedule from an unprotected branch to a protected branch.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 9.2 · fixed in 16.4.3; From 16.5 · fixed in 16.5.3; From 16.6 · fixed in 16.6.1

References 2

gitlab.com

hackerone.com