Skip to main content
← All vulnerabilities
CVE-2023-42457GHSA-H6RP-MPRM-XGCQPYSEC-2023-178

plone.rest vulnerable to Denial of Service when ++api++ is used many times

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.1, 3.0.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

plone.rest allows users to use HTTP verbs such as GET, POST, PUT, DELETE, etc. in Plone. Starting in the 2.x branch and prior to versions 2.0.1 and 3.0.1, when the `++api++` traverser is accidentally used multiple times in a url, handling it takes increasingly longer, making the server less responsive. Patches are available in `plone.rest` 2.0.1 and 3.0.1. Series 1.x is not affected. As a workaround, one may redirect `/++api++/++api++` to `/++api++` in one's frontend web server (nginx, Apache).

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • plone plone.rest

    From 2.0.0a1 · fixed in 2.0.1

  • plone-restPyPI

    From 2.0.0a1 · fixed in 2.0.1

  • plone-restPyPI

    From 3.0.0 · fixed in 3.0.1

  • plone-restPyPI

    All versions

References 4

GitHub · plone/plone.rest

openwall.com