Skip to main content
← All vulnerabilities
CVE-2023-40314GHSA-C6XW-HG9Q-3C9F

Cross-site scripting in bootstrap.jsp

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 32.0.4, 32.0.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Moshe Apelbaum for reporting this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • The OpenNMS Group Horizon

    From 31.0.8 · fixed in 32.0.4

  • The OpenNMS Group Meridian

    Version range not reported

  • org.opennms:opennms-webappMaven

    fixed in 32.0.5

References 1

GitHub · OpenNMS/opennms