Skip to main content
← All vulnerabilities
CVE-2023-39527GHSA-XW2R-F8XV-C8XP

PrestaShop XSS vulnerability through Validate::isCleanHTML method

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.7.8.10, 8.0.5, 8.1.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to cross-site scripting through the `isCleanHTML` method. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • PrestaShop PrestaShop

    fixed in 1.7.8.10; From 8.0.0 · fixed in 8.0.5

  • prestashop/prestashopPackagist

    From 8.1.0 · fixed in 8.1.1

  • prestashop/prestashopPackagist

    From 8.0.0 · fixed in 8.0.5

  • prestashop/prestashopPackagist

    fixed in 1.7.8.10

References 2

GitHub · PrestaShop/PrestaShop