CVE-2023-39526GHSA-GF46-PRM4-56PC
PrestaShopSQL manager vulnerability (potential RCE)
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.7.8.10, 8.0.5, 8.1.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to remote code execution through SQL injection and arbitrary file write in the back office. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- PrestaShop PrestaShop
fixed in 1.7.8.10; From 8.0.0 · fixed in 8.0.5
- prestashop/prestashopPackagist
From 8.1.0 · fixed in 8.1.1
- prestashop/prestashopPackagist
From 8.0.0 · fixed in 8.0.5
- prestashop/prestashopPackagist
fixed in 1.7.8.10