Skip to main content
← All vulnerabilities
CVE-2023-39441PYSEC-2026-2371BIT-AIRFLOW-2023-39441GHSA-5F35-PQ34-C87QPYSEC-2026-1130PYSEC-2026-2368

Apache Airflow SMTP Provider, Apache Airflow IMAP Provider, Apache Airflow: SMTP/IMAP client components allowed MITM due to missing Certificate Validation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.30, 3.3.0, 2.7.0, 1.3.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate.  Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Airflow SMTP Provider

    fixed in 1.30

  • Apache Software Foundation Apache Airflow IMAP Provider

    fixed in 3.3.0

  • Apache Software Foundation Apache Airflow

    fixed in 2.7.0

  • apache-airflow-providers-smtpPyPI

    fixed in 1.3.0

  • apache-airflow-providers-imapPyPI

    fixed in 3.3.0

  • apache-airflowPyPI

    fixed in 2.7.0

References 5

GitHub · apache/airflow

lists.apache.org

openwall.com