Skip to main content
← All vulnerabilities
CVE-2023-3917

Improper Validation of Specified Type of Input in GitLab

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 16.2.8, 16.3.5, 16.4.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Denial of Service in pipelines affecting all versions of Gitlab EE and CE prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1 allows attacker to cause pipelines to fail.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitLab GitLab

    fixed in 16.2.8; From 16.3 · fixed in 16.3.5; From 16.4 · fixed in 16.4.1

References 2

gitlab.com

hackerone.com